pukiwikiのPHP7への対応について

公式でPHP7への対応済みと記載あるんですが、PHP7.1で動かしたらエラーだらけでした。
主な原因は

  • コンストラクタの定義の仕方がクラス名と同じまま
  • 関数の引数の数があってないまま呼び出してる箇所が多数ある
  • PHP7で更新された関数の利用方法が古いまま

そこまで大変じゃないけど一個一個エラー原因特定するの面倒だった。
これからpukiwikiをPHP7で運用する予定の方はご注意を。

シェアする

  • このエントリーをはてなブックマークに追加

フォローする